1. Welcome to Oklahoma Shooters Association! Join today, registration is easy!

    You can register using your Google, Facebook, or Twitter account, just click here.
  2. All members receive 3 free listings a month. Get unlimited listings for just $10 a year! Click here for all the info.

Trident 9 g19 woes

Discussion in 'NFA & Class III Discussion' started by dubs chops, Apr 16, 2012.

  1. dubs chops

    dubs chops Sharpshooter

    Messages:
    2,780
    Likes Received:
    7
    Joined:
    May 6, 2009
    Location:
    Inola
    OK so I was out and about this weekend and decided to run a few boxes through the trident 9. about mid way through the first box I start getting all kinds of FTF, FTE's So I take the gun and the can down and clean them. Neither one seems particularly dirty. Put them back together and I get the same problem. The only thing I can think of that I have done different than I ever do is I decided to run the can wet so I poured some bottled water into the baffles. MAN is it quite that way. Anyways anyone have any ideas of what would be causing this? I also took the piston apart and it didn't seem to be binding or anything like that.
     
  2. bilboben

    bilboben Sharpshooter

    Messages:
    205
    Likes Received:
    0
    Joined:
    Jul 27, 2009
    Location:
    Duncan, Ok
    Did you run the gun w/o the can to see if it was malfunctioning by itself?
     
  3. Glocktogo

    Glocktogo Sharpshooter

    Messages:
    25,551
    Likes Received:
    5,742
    Joined:
    Jan 12, 2007
    Location:
    Collinsville
    Rating
    100%
    Did you move the piston manually to make sure there was no binding in the travel? Even when I clean & lube mine, I find it helps to move it back and forth to let the lube filter into the spots that may bind before I resume firing.
     
  4. 338Shooter

    338Shooter Sharpshooter

    Messages:
    17,342
    Likes Received:
    9
    Joined:
    Mar 12, 2008
    Location:
    Get off my lawn.
    Rating
    100%
    Once the trident piston gets all dried out and crusty it can do that. With the can mounted just pull on it to see if it feels gritty as the piston moves.

    I've got about 30k through my Trident, but I mostly shoot the 3 lug. I find the booster mount only works well for a couple hundred rounds before it needs decarboned and regreased.
     
  5. dubs chops

    dubs chops Sharpshooter

    Messages:
    2,780
    Likes Received:
    7
    Joined:
    May 6, 2009
    Location:
    Inola
    I will Try regreasing it. It does slide fine. Haven't felt any binding but could probably use to be smoother. I have it soaking in WD-40 at home as we speak.
     
  6. 338Shooter

    338Shooter Sharpshooter

    Messages:
    17,342
    Likes Received:
    9
    Joined:
    Mar 12, 2008
    Location:
    Get off my lawn.
    Rating
    100%
    WD-40 doesn't do anything except make it smoke like a freight train next time out.
     
  7. Glocktogo

    Glocktogo Sharpshooter

    Messages:
    25,551
    Likes Received:
    5,742
    Joined:
    Jan 12, 2007
    Location:
    Collinsville
    Rating
    100%
    And spit flecks of greasy black stuff all over you! :)
     
  8. 338Shooter

    338Shooter Sharpshooter

    Messages:
    17,342
    Likes Received:
    9
    Joined:
    Mar 12, 2008
    Location:
    Get off my lawn.
    Rating
    100%
    No doubt!
     
  9. dubs chops

    dubs chops Sharpshooter

    Messages:
    2,780
    Likes Received:
    7
    Joined:
    May 6, 2009
    Location:
    Inola
    OK. Well the piston is pretty clean and seems to be moving freely. I went ahead and greased it. Still no go I am either getting a FTE or shell stuck halfway out of the slide every time. Yes I did check the function of the firearm without the can on it and it was fine. What could have changed so quickly to have caused this that is severe enough to cause a FTE every time yet I am not finding it?
     
  10. 338Shooter

    338Shooter Sharpshooter

    Messages:
    17,342
    Likes Received:
    9
    Joined:
    Mar 12, 2008
    Location:
    Get off my lawn.
    Rating
    100%
    What ammo are you using? Some of my reloads are light enough they are on the hairs edge of not working in the gun. I would suggest a lighter recoil spring for the glock.
     

Share This Page